top
Вход

Поддержка24

Важно! Возможные проблемы с подключением к сайтам, магазинам Битрикс24 с 30 сентября 2021

С 30 сентября 2021 17:01 (МСК) могут наблюдаться проблемы у клиентов со старой версией браузеров или операционной системы, а также на собственных серверах или хостинге:

  • при подключении к сайтам и магазинам Битрикс24;
  • при подключении к Битрикс24 с услугой «собственный домен» (тарифы «Профессиональный» и архивный «Компания»);
  • при выполнении API REST-запросов со своего сервера к Битрикс24.

Это связано с тем, что срок действия корневого сертификата DST Root CA X3 истек, но он участвует в цепочке выдаваемых нами клиентских сертификатов от Let's Encrypt и остается до 2024 года для поддержки устройств с Android версий 2.3.6-7.1.1.


Что делать?

Единственное верное решение – использование актуального ПО клиентами. Иными словами, обновите ваши устройства и браузеры до последних версий.

Если вы используете виртуальную машину VMBitrix на своем сервере, то необходимо обновить пакет ca-certificates с помощью команды:

yum update -y ca-certificates

Если вы используете другое серверное окружение, то обратитесь к системному администратору вашего сервера.


Подключение к сайтам и порталам

Проблема не касается:

  • Windows >= XP SP3 (с автоматическим обновлением)
  • macOS >= 10.12.1
  • iOS >= 10
  • Android >= 7.1.1
  • Mozilla Firefox >= 50.0
  • Ubuntu >= xenial / 16.04 (с обновлениями)
  • Debian >= jessie / 8 (с обновлениями)
  • Java 8 >= 8u141
  • Java 7 >= 7u151
Работа браузеров Chrome, Safari, Edge, Opera, Vivaldi будет зависеть от версии ОС, на которой они установлены.

Во всех остальных случаях могут наблюдаться проблемы с подключением, будет выдаваться ошибка об истечении срока действия сертификатов при заходе на сайты, магазины Битрикс24 и порталы со своим доменом.


Выполнение REST/API запросов

Проблема будет, в основном, затрагивать клиентов при выполнении API-запросов с серверов со старым ПО, которые используют:

  • openssl-1.0.1 – полностью несовместим и работать не будет без сбора собственных пакетов (CentOS 6).
  • openssl-1.0.2 – необходимо обновить пакет ca-certificates на серверах (CentOS 7).
  • openssl-1.1.x – полностью совместим.

Для решения этой проблемы, обратитесь к системному администратору вашего сервера.


Подробнее про совместимость корневого сертификата DST Root CA X3 с устройствами и операционными системами можно прочитать в документации Let's Encrypt.


Спасибо, помогло!
Спасибо :)
Необязательно:
Оставить отзыв о статье
Не помогло
Очень жаль :(
Уточните, пожалуйста, почему:
Это не то, что я ищу
Очень сложно и непонятно
Оставить отзыв о статье
Помощь партнера